Problem with VirtualMin installation on Centos 5.6

Downloaded the install.sh script from their website.
Ran yum update
sh /tmp/install.sh

and getting the following:

Displaying the last 15 lines of /root/virtualmin-install.log to help troubleshoot this problem:
—> Package keyutils-libs-devel.x86_64 0:1.2-1.el5 set to be updated
—> Package libselinux-devel.x86_64 0:1.33.4-5.7.el5 set to be updated
–> Processing Dependency: libsepol-devel >= 1.15.2-1 for package: libselinux-devel
—> Package perl-Digest-SHA1.x86_64 0:2.11-1.2.1 set to be updated
–> Running transaction check
–> Processing Dependency: httpd = 2.2.3-53.el5.centos.1 for package: httpd-devel
—> Package libsepol-devel.x86_64 0:1.15.2-3.el5 set to be updated
–> Finished Dependency Resolution
httpd-devel-2.2.3-53.el5.centos.1.i386 from installed has depsolving problems
–> Missing Dependency: httpd = 2.2.3-53.el5.centos.1 is needed by package httpd-devel-2.2.3-53.el5.centos.1.i386 (installed)

The problem is clear from the very last line. This is a x64 system and httpd-devel.i386 is present by default. Did a ‘yum -y remove http-devel.i386’ and it solved the problem.

Leave a Reply

Your email address will not be published. Required fields are marked *